package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\[module[^]]*id="[^"]*\d)(.*?)(\[\/module[^]]*\])`)
var str = `[section][module_text id="123"]text[/module][module_number id=""]000[/module][/section]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}