const regex = new RegExp('something\\((.+),(.+)\\)', 'gm')
const str = `something(name_one,name_two).`;
const subst = `something(\2,\1)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);