using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"("".*?(?<!\\)"")\s*:\s*("".*?(?<!\\)"")";
string input = @"{""a"":""some value"", ""b"":""some : value"", ""\""f"":"", ""This is \"" a key "": ""some ,\"" va\""lue\""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}