re = /(".*?(?<!\\)")\s*:\s*(".*?(?<!\\)")/m
str = '{"a":"some value", "b":"some : value", "\\"f":"", "This is \\" a key ": "some ,\\" va\\"lue\\""}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end