// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"www\.hasbro\.com\/(.{1,10})\/\s?$").unwrap();
let string = "https://www.hasbro.com/zh-hant-tw/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}