re = /\b( )\b/
str = 'test a one.
test a two.
test a three.
test a four.
test a five.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end