re = /(&[lmnok])(.*?)(&r|$)/m
str = ' plain &kobfuscated &r&lbold &r&mstrikethrough &r&nunderline &r&oitalic &r&l&mbold-strikethrough &r&lbold &mbold-strikethrough &rplain'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end