# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.+?(abcd|Eqhab|guo=98)\1.+/$1/gm;t' <<< "abcdabcdabcdabcdabcdabcdabcdabcd
EqhabEqhabEqhabEqhabEqhab
o98guo=98guo=98guo=98guo=98guo=98guo=98guo98"