#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).+?(abcd|Eqhab|guo=98)\1.+"
Local $sString = "abcdabcdabcdabcdabcdabcdabcdabcd" & @CRLF & _
"EqhabEqhabEqhabEqhabEqhab" & @CRLF & _
"o98guo=98guo=98guo=98guo=98guo=98guo=98guo98"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)