using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+?(abcd|Eqhab|guo=98)\1.+";
string substitution = @"$1";
string input = @"abcdabcdabcdabcdabcdabcdabcdabcd
EqhabEqhabEqhabEqhabEqhab
o98guo=98guo=98guo=98guo=98guo=98guo=98guo98";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}