const regex = /.+?(abcd|Eqhab|guo=98)\1.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+?(abcd|Eqhab|guo=98)\\1.+', 'gm')
const str = `abcdabcdabcdabcdabcdabcdabcdabcd
EqhabEqhabEqhabEqhabEqhab
o98guo=98guo=98guo=98guo=98guo=98guo=98guo98`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);