re = /[A-Z](?<![a-zA-Z][A-Z])(?:[A-Z]|[-\s\/\\])*(?<=[A-Z])(?![a-zA-Z])/m
str = 'example 1:
string = string = \'MY MANAGEMENT PRIOR ASSESSMENT / NEW PLANNING SUPRESS RATE - TEAM : 14
example 2:
string2 = \'SPORT/TRACK INFO ¶·»Sport Coverage(s): All Sport primary ¶·»WWE Hi-Low: ¶·»BBC Hi-Low: ¶·»Sports Issues: can run forever ¶·»BBC Sports: kjkj \'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end