# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:([^\.]{2,3}(?![^\.])\+?).*|.*\.(.*))([0-9]{2})$/$1$2$3/gm;t' <<< "BCPP.Boc+20
BCP+.Boc+20
Boc.Boc+20
BCP.Boc+20
BC.Boc+20
"