#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:([^\.]{2,3}(?![^\.])\+?).*|.*\.(.*))([0-9]{2})$"
Local $sString = "BCPP.Boc+20" & @CRLF & _
"BCP+.Boc+20" & @CRLF & _
"Boc.Boc+20" & @CRLF & _
"BCP.Boc+20" & @CRLF & _
"BC.Boc+20" & @CRLF & _
""
Local $sSubst = "$1$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)