$re = '/(?:([^\.]{2,3}(?![^\.])\+?).*|.*\.(.*))([0-9]{2})$/m';
$str = 'BCPP.Boc+20
BCP+.Boc+20
Boc.Boc+20
BCP.Boc+20
BC.Boc+20
';
$subst = "$1$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;