const regex = /(^|\s)(https?:\/\/(www\.)?|www\.)[a-zA-Z0-9-]+(\.[a-zA-Z]{2,})+(\/[a-zA-Z0-9-._~!$&'()*+,;=:@\/]*)*\/?(?=$|\s|[^\w])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\s)(https?:\\\/\\\/(www\\.)?|www\\.)[a-zA-Z0-9-]+(\\.[a-zA-Z]{2,})+(\\\/[a-zA-Z0-9-._~!$&\'()*+,;=:@\\\/]*)*\\\/?(?=$|\\s|[^\\w])', 'g')
const str = `this is just some https://dn.dk random text, www.dn.dk/ bla bla bla but wait https://www.dn.dk/arrangementer here is a domain www.dn.dk.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}