// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<pre>((?:[^\n]+?))</pre>").unwrap();
let string = "<pre>one</pre><p><b>two</b></p>\\n<pre>DO NOT MATCH</pre><pre>BALLS</pre>";
let substitution = "<p>$1</p>\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}