using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^#[0-9A-Fa-f]{6}$)|(^#[0-9A-Fa-f]{3,4}$)|(^#[0-9A-Fa-f]{8}$)";
string input = @"// good case
#000
#123
#999
#AAA
#aaa
#abc
#FFF
#0000
#9999
#AAAA
#aaaa
#abcd
#FFFF
#ffff
#000000
#456789
#999999
#AAAAAA
#aaaaaa
#abcdef
#FFFFFF
#ffffff
#00000000
#12345678
#99999999
#AAAAAAAA
#aaaaaaaa
#abcdefcc
#FFFFFFFF
#ffffffff
#00123456
//bad case
##
#0
#1
#F
#f
#12
#AB
#ae
#aaaaa
#fffff
#aaaah
#aaaaaaa
#0000000
#ffffhij
#h000000
#aaaaaaai
#000k0123
#asdfasfa
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}