# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^#[0-9A-Fa-f]{6}$)|(^#[0-9A-Fa-f]{3,4}$)|(^#[0-9A-Fa-f]{8}$)"
test_str = ("// good case\n"
"#000\n"
"#123\n"
"#999\n"
"#AAA\n"
"#aaa\n"
"#abc\n"
"#FFF\n"
"#0000\n"
"#9999\n"
"#AAAA\n"
"#aaaa\n"
"#abcd\n"
"#FFFF\n"
"#ffff\n"
"#000000\n"
"#456789\n"
"#999999\n"
"#AAAAAA\n"
"#aaaaaa\n"
"#abcdef\n"
"#FFFFFF\n"
"#ffffff\n"
"#00000000\n"
"#12345678\n"
"#99999999\n"
"#AAAAAAAA\n"
"#aaaaaaaa\n"
"#abcdefcc\n"
"#FFFFFFFF\n"
"#ffffffff\n"
"#00123456\n\n\n"
"//bad case\n"
"##\n"
"#0\n"
"#1\n"
"#F\n"
"#f\n"
"#12\n"
"#AB\n"
"#ae\n"
"#aaaaa\n"
"#fffff\n"
"#aaaah\n"
"#aaaaaaa\n"
"#0000000\n"
"#ffffhij\n"
"#h000000\n"
"#aaaaaaai\n"
"#000k0123\n"
"#asdfasfa\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.