// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^#[0-9A-Fa-f]{6}$)|(^#[0-9A-Fa-f]{3,4}$)|(^#[0-9A-Fa-f]{8}$)").unwrap();
let string = "// good case
#000
#123
#999
#AAA
#aaa
#abc
#FFF
#0000
#9999
#AAAA
#aaaa
#abcd
#FFFF
#ffff
#000000
#456789
#999999
#AAAAAA
#aaaaaa
#abcdef
#FFFFFF
#ffffff
#00000000
#12345678
#99999999
#AAAAAAAA
#aaaaaaaa
#abcdefcc
#FFFFFFFF
#ffffffff
#00123456
//bad case
##
#0
#1
#F
#f
#12
#AB
#ae
#aaaaa
#fffff
#aaaah
#aaaaaaa
#0000000
#ffffhij
#h000000
#aaaaaaai
#000k0123
#asdfasfa
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}