import Foundation
let pattern = ##"(^#[0-9A-Fa-f]{6}$)|(^#[0-9A-Fa-f]{3,4}$)|(^#[0-9A-Fa-f]{8}$)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ###"""
// good case
#000
#123
#999
#AAA
#aaa
#abc
#FFF
#0000
#9999
#AAAA
#aaaa
#abcd
#FFFF
#ffff
#000000
#456789
#999999
#AAAAAA
#aaaaaa
#abcdef
#FFFFFF
#ffffff
#00000000
#12345678
#99999999
#AAAAAAAA
#aaaaaaaa
#abcdefcc
#FFFFFFFF
#ffffffff
#00123456
//bad case
##
#0
#1
#F
#f
#12
#AB
#ae
#aaaaa
#fffff
#aaaah
#aaaaaaa
#0000000
#ffffhij
#h000000
#aaaaaaai
#000k0123
#asdfasfa
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)