#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^/]*/(?!admin/)(?:[^/\n]+/)+$"
Local $sString = "localhost:8000/admin/mymodel/something/" & @CRLF & _
"localhost:8000/something" & @CRLF & _
"localhost:8000/something/" & @CRLF & _
"localhost:8000/something/something/something/" & @CRLF & _
"localhost:8000" & @CRLF & _
"something/" & @CRLF & _
"/someting/a/" & @CRLF & _
"/someting//a/a/" & @CRLF & _
"/someting//" & @CRLF & _
"/someting//something//" & @CRLF & _
"/someting/something//" & @CRLF & _
"/someting//something//" & @CRLF & _
"something/something/" & @CRLF & _
"something/admin/something/" & @CRLF & _
"/something/admin/something/" & @CRLF & _
"/admin/" & @CRLF & _
"/admin/green/yellow/" & @CRLF & _
"/admin/hello/" & @CRLF & _
"/admin/hello/hello/" & @CRLF & _
"/admin/hello/hello/hello/" & @CRLF & _
"/admin/hello/hello" & @CRLF & _
"admin/" & @CRLF & _
"admin/green/yellow/" & @CRLF & _
"admin/hello/" & @CRLF & _
"/notadmin/path/something" & @CRLF & _
"/something/admin/something/" & @CRLF & _
"/what/is/happening/" & @CRLF & _
"/no_admin/yellow/" & @CRLF & _
"/no_admin/yellow/green/red/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")