// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*").unwrap();
let string = "Abby.O’connor@test.org
Abby.O'connor@test.org
AbbyO'&^%@#$connor@test.org
abbyoconnor@test.org
abbyoor@te.org
abb.yoor@t.e.s.rg
abby!oconnor@test.org
ab#byoconnor@test.org
abb$yoconnor@test.org
abb*yoconnor@test.org
abbyoc-onnor@test.org
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}