re = /^(\d{3})(\d{1,3})?(\d{1,3})?(\d{1,2})?$/m
str = '011
0112
01121
011212
01121212
0112121234
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end