# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^-\K|[^-\d\n.]//gm;t' <<< "2,564.30
-2,564.30"