$re = '/(?<=\])(.*?)(?=\[\/)/m';
$str = '[hello_world with="attribute"]And some [more-complex] content[/hello_world]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);