$re = '/__ent_0*(\d+)_/m';
$str = '__ent_00000_Bye bye StackOverflow! __ent_00001_';
$subst = "<ph$1/>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;