$re = '/<div>(.*?)<\/div>/m';
$str = '<div>
<div><h1>Title<h2></div>
<p>text</p>
<div>delete me</div>
<div><p>text</p></div>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);