re = /<div>(.*?)<\/div>/m
str = '<div>
<div><h1>Title<h2></div>
<p>text</p>
<div>delete me</div>
<div><p>text</p></div>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end