// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<div>(.*?)<\/div>").unwrap();
let string = "<div>
<div><h1>Title<h2></div>
<p>text</p>
<div>delete me</div>
<div><p>text</p></div>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}