using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[\w']+\b";
string input = @"Lorem ipsum dolor sit amet, consectetur adipiscing elit. Donec ut vehicula mauris, ac condimentum turpis. Donec at molestie velit, nec vehicula libero. Pellentesque nisl est, efficitur vel cursus eu, egestas et elit. Aliquam a molestie diam, nec bibendum orci. Praesent venenatis eu felis varius tempor. Nunc gravida commodo vehicula. Aenean luctus nulla ac sem tincidunt, ut sollicitudin nulla aliquam. Maecenas finibus convallis pretium. Pellentesque sed porttitor dui.
Maecenas at metus eget risus pulvinar dignissim. Orci varius natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Etiam venenatis sollicitudin lobortis. Praesent ornare diam eu ligula feugiat, nec rutrum neque venenatis. Phasellus tempus consequat te'mpus. Nulla facilisi. Proin magna mauris, varius vel ullamcorper ac, congue eget diam. Cras consequat id arcu et posuere. Morbi eu augue ut orci egestas sodales in vel tellus. Ut malesuada metus mattis sollicitudin vulputate.
Praesent quis lacus elit. Phasellus ullamcorper eget elit vel hendrerit. Integer egestas maximus velit eu ultricies. Ut ut condimentum leo, et euismod magna. Cras quis lobortis urna. Sed elementum tempus nulla ut posuere. Vivamus finibus nisl enim, non consectetur felis interdum eu. Aliquam nec varius lectus, eget hendrerit massa.
Vestibulum sollicitudin tincidunt sapien, eget laoreet sem luctus at. Vivamus ac dolor condimentum, lacinia arcu ut, ultrices dolor. Praesent a volutpat mauris. Fusce eget leo vel erat laoreet mollis. Sed eu mollis risus. Mauris vitae justo in ligula sagittis congue. Sed at dui nec quam molestie tempus. Orci varius natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Vestibulum interdum purus a risus tincidunt, eu aliquet dolor vulputate. Suspendisse accumsan massa in erat suscipit cursus. Sed semper nisi sed tellus maximus sagittis. Aenean iaculis laoreet libero, non venenatis dolor mollis in. Morbi sed fringilla dolor, eget accumsan lorem. Sed tristique placerat leo sed convallis.
Suspendisse mollis metus aliquet congue dapibus. Curabitur finibus, nibh a imperdiet pretium, urna ipsum pharetra felis, vitae cursus neque nibh et nisl. Pellentesque interdum magna quis massa tempus, vitae mollis arcu placerat. Nullam dictum ipsum ac consectetur commodo. Fusce ac scelerisque risus. Aliquam non finibus tortor. Suspendisse et molestie est, et porttitor sem.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}