$re = '/\b\d{7}\b(?=(?:(?!\b\d{7}\b).)*incomplete n/a).*?$/m';
$str = '1281674 the crescent annandale 02/10/2019 16/10/2019 - 16/11/2019 pending 1281640 city west link rd lilyfield 02/10/2019 16/10/2019 - 16/11/2019 pending 1276160 victoria rd rozelle 25/09/2019 14/10/2019 - 15/10/2019 pending 1331626 31/12/2019 - 31/01/2020 incomplete n/a 1281674 the crescent annandale 02/10/2019 16/10/2019 - 16/11/2019';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;