using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^.*?=";
string substitution = @"";
string input = @"ErrorMoving=You cannot=another.
ErrorTooMuchActions
=Too many changes=.{k}=12=aa
WorldErrorWait=An error has occurred.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}