re = /[.][mp3]+/m
str = 'lista de arquivos mp3: jazz.mp3,rock.mp3,podcast.mp3,blues.mp3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end