re = /((\d{4})(-| )(\d{3})(-| )(\d{4})|((04|\+61)(\d{10}|\d{9}|\d{8}))|((04|\+04|61|\+61)( |-)(\d{1})( |-)(\d{4}|\d{3})( |-)(\d{4}|\d{3})))/m
str = 'regex australian phone number format (e.g. 0412-123-4567) or (e.g. 0412 123 4567) or (e.g. 0412-123 4567) or (e.g. 0412345678) or (e.g. +61 4 1234 5678) or (e.g. +61 4 1234 567) or (e.g. +6101234567) or (e.g. +61012345678)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end