// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<a.*?class="[^"]*_2s25 ._606w[^"]*".*?href="([^"]+)".*?<\/a>"#).unwrap();
let string = "<a class=\"\"asdfasdfsadf
<a class=\"_2s25 ._606w\"bla bla bla bla bla bla sdafjkasdfa href=\"https://www.facebook.com/AnteSoftTech\" bla bla bla title=\"bla bla\" ......................<img>bla</img>.<span></span>..................................</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}