import Foundation
let pattern = #"<a.*?class="[^"]*_2s25 ._606w[^"]*".*?href="([^"]+)".*?<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<a class=""asdfasdfsadf
<a class="_2s25 ._606w"bla bla bla bla bla bla sdafjkasdfa href="https://www.facebook.com/AnteSoftTech" bla bla bla title="bla bla" ......................<img>bla</img>.<span></span>..................................</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)