package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#([^#]*)#=([^#]*)(?:;|$)`)
var str = `#aaaa#=1111;#bbbbb#=2222;#cccc#=33;333;#cccc#=33;333`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}