re = /(https?:\/\/.*)(:\d*)\/?(.*)/m
str = 'https://some.domain.biz:8320/path/to/there/123456'
subst = '$1/$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result