$re = '/<a>.*?<\/a>/m';
$str = 'bla bla <a>Whatever</a> bla bla <a>Whatever</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);