import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\b([QI]{2}|[Q])[\\\\s || -]{0,2}[0-9]{5,}[\\\\s || -]{0,2}\\K[A-Z]{3}\\b";
final String string = "The quote number is Q-123123-PAD with many QI123123 PAD AB01231231PAD \n"
+ "Q-12311-APD \n"
+ "the the the the the";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}