package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S+$`)
var str = `DL666 DL777 DL888 这波值不值你下载`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}