#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^|;)"(?:""|[^";])*[\n\r]+(?:""|[^";])*""
Local $sString = "test;"123";"this description with new line feed below should be" & @CRLF & _
"matched by regex";test;"1.0"" & @CRLF & _
"" & @CRLF & _
"NewLine1;"test - this one should not be captured by the regex but its being captured ";test;1" & @CRLF & _
"NewLine2;"test that went wrong""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")