package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|;)"(?:""|[^";])*[\n\r]+(?:""|[^";])*"`)
var str = `test;"123";"this description with new line feed below should be
matched by regex";test;"1.0"
NewLine1;"test - this one should not be captured by the regex but its being captured ";test;1
NewLine2;"test that went wrong"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}