# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^|;)\"(?:\"\"|[^\";])*[\n\r]+(?:\"\"|[^\";])*\""
test_str = ("test;\"123\";\"this description with new line feed below should be\n"
"matched by regex\";test;\"1.0\"\n\n"
"NewLine1;\"test - this one should not be captured by the regex but its being captured \";test;1\n"
"NewLine2;\"test that went wrong\"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.