// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(^|;)"(?:""|[^";])*[\n\r]+(?:""|[^";])*""#).unwrap();
let string = "test;\"123\";\"this description with new line feed below should be
matched by regex\";test;\"1.0\"
NewLine1;\"test - this one should not be captured by the regex but its being captured \";test;1
NewLine2;\"test that went wrong\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}