# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:BP:?(?:-Sitting)?|Blood Pressure) \d+/\d+(?: mmHg?)?|B/P - (?:Sys|Dias)tolic \d+|(?:Sys|Dias)tolic Blood Pressure \d+ \w+\b"
test_str = ("BP 98/60\n"
"BP 108/60\n"
"BP 96/60\n"
"BP 120/75\n"
"Blood Pressure 106/63\n"
"B/P - Systolic 104\n"
"B/P - Diastolic 72\n"
"BP-Sitting 109/70 mmH\n"
"BP: 101/72\n"
"Systolic Blood Pressure 100 mmHg\n"
"Diastolic Blood Pressure 68 mmHg")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.