import re
regex = re.compile(r"(@\w+)")
test_str = "@word1 <p>ipsum dolor sit @word2 amet, consectetur adipiscing elit. Ut facilisis accumsan augue, <span>@word3</span>@word4 eget laoreet elit efficitur ut. sample@domain.com Fusce nulla ante, aliquam vel est sed, fringilla auctor risus. Ut consectetur mi non felis tincidunt, sit amet tincidunt massa placerat.</p>@word5"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")