$re = '/(?<!\S)\d+(?:,\d{3})*(?:\.\d+)?\b/m';
$str = '0,000.1 $100,000.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);