$re = '/^[^a\n\r]*\b([^\Wa]*a\w*)/m';
$str = 'The cat ate the dog
and the mouse
this is a test
a
when will this be matching?
@!#SSDF2#$@a#$dsfs$sdfdsdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);